& in connections Name=" aaa & bbb" connection file won't load

Description

When trying to open connection file with & in the Connections Name=" " causes this error in the log.

An error occurred while parsing EntityName. Line 2, position 26.
at System.Xml.XmlTextReaderImpl.Throw(Exception e)
at System.Xml.XmlTextReaderImpl.Throw(String res, Int32 lineNo, Int32 linePos)
at System.Xml.XmlTextReaderImpl.HandleEntityReference(Boolean isInAttributeValue, EntityExpandType expandType, Int32& charRefEndPos)
at System.Xml.XmlTextReaderImpl.ParseAttributeValueSlow(Int32 curPos, Char quoteChar, NodeData attr)
at System.Xml.XmlTextReaderImpl.ParseAttributes()
at System.Xml.XmlTextReaderImpl.ParseElement()
at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
at System.Xml.XmlTextReaderImpl.Read()
at System.Xml.XmlLoader.LoadNode(Boolean skipOverWhitespace)
at System.Xml.XmlLoader.LoadDocSequence(XmlDocument parentDoc)
at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
at System.Xml.XmlDocument.Load(XmlReader reader)
at System.Xml.XmlDocument.LoadXml(String xml)
at mRemoteNG.Config.Connections.Load.LoadFromXML(String cons, Boolean import) in C:\Users\Riley\Documents\Visual Studio 2010\Projects\mRemoteNG\mRemoteV1\Config\Config.Connections.Load.vb:line 654
2013-11-04 08:31:35,947 [1] ERROR- Connections file "C:\Users\test\Desktop\test_test.xml" could not be loaded!

In 1.71 RC3 the error will not allow the connections file to open. In 1.70 the file opens but the error is still in the log.

Personally I don't see an issue with not allowing & but the error shouldn't go and look in C:\User\Riley for anything.

Environment

Windows 7 64

Status

Assignee

Riley McArdle

Reporter

William Scanlon

Labels

Affects versions

Priority

Minor
Configure